summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-04-06 12:37:33 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-04-06 12:37:33 +0200
commit3b262b51fa616e3809b7bad450e288359845028a (patch)
treebc2a482389c9dd0dcb44d740ffaf97b204396398
parente1df15794b8e72dc24a8855c696f17009d647fa8 (diff)
downloadguix-3b262b51fa616e3809b7bad450e288359845028a.tar.gz
gnu: python-pybtex: Update to 0.24.0.
* gnu/packages/python-xyz.scm (python-pybtex): Update to 0.24.0.
[native-inputs]: Remove python-nose; add python-pytest.
[inputs]: Move python-latexcodec, python-pyyaml, and python-six from here...
[propagated-inputs]: ...to here.
[arguments]: Use pytest.
-rw-r--r--gnu/packages/python-xyz.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2e3f766113..55705ab2ea 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -22002,17 +22002,17 @@ working with iterables.")
 (define-public python-pybtex
   (package
     (name "python-pybtex")
-    (version "0.22.2")
+    (version "0.24.0")
     (source
      (origin
        (method url-fetch)
        (uri (pypi-uri "pybtex" version))
        (sha256
-        (base32 "070wfcmxrd7xg1si421mi9150gmx2qwx431nwf69sq3hhmgnx080"))))
+        (base32 "0ma7sc10hk6caq5zghbk865vrlaynz7x5z630z0facqpnqssx3l1"))))
     (build-system python-build-system)
     (native-inputs
-     (list python-nose))
-    (inputs
+     (list python-pytest))
+    (propagated-inputs
      (list python-latexcodec python-pyyaml python-six))
     (arguments
      (list
@@ -22020,7 +22020,7 @@ working with iterables.")
                    (replace 'check
                      (lambda* (#:key tests? #:allow-other-keys)
                        (when tests?
-                         (invoke "nosetests")))))))
+                         (invoke "pytest")))))))
     (home-page "https://pybtex.org/")
     (synopsis "BibTeX-compatible bibliography processor")
     (description "Pybtex is a BibTeX-compatible bibliography processor written