summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2022-08-13 18:28:15 +0200
committerJulien Lepiller <julien@lepiller.eu>2022-08-13 21:21:22 +0200
commit42d5f769fb940912b2a64e8d0b2528e492684ef5 (patch)
tree48be7eea74e1c9a914c03d13de3f4bb730b1fc88
parentb4d97ef2dee113eec1307207874253c4a2e39e39 (diff)
downloadguix-42d5f769fb940912b2a64e8d0b2528e492684ef5.tar.gz
gnu: dune: Update to 4.4.1.
* gnu/packages/ocaml.scm (dune): Update to 4.4.1.
* gnu/packages/coq.scm (coq-stdlib): Fix for new dune.
-rw-r--r--gnu/packages/coq.scm13
-rw-r--r--gnu/packages/ocaml.scm4
2 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/coq.scm b/gnu/packages/coq.scm
index bbb6c4d435..bbb34df27d 100644
--- a/gnu/packages/coq.scm
+++ b/gnu/packages/coq.scm
@@ -101,7 +101,18 @@ It is developed using Objective Caml and Camlp5.")
     (name "coq-stdlib")
     (arguments
      `(#:package "coq-stdlib"
-       #:test-target "."))
+       #:test-target "."
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'fix-dune
+           (lambda _
+             (substitute* "user-contrib/Ltac2/dune"
+               (("coq-core.plugins.ltac2")
+                (string-join
+                  (map (lambda (plugin) (string-append "coq-core.plugins." plugin))
+                       '("ltac2" "number_string_notation" "tauto" "cc"
+                         "firstorder"))
+                  " "))))))))
     (inputs
      (list coq-core gmp ocaml-zarith))
     (native-inputs '())))
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 63fa716c27..9968771bfc 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1705,7 +1705,7 @@ full_split, cut, rcut, etc..")
 (define dune-bootstrap
   (package
     (name "dune")
-    (version "3.3.1")
+    (version "3.4.1")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1714,7 +1714,7 @@ full_split, cut, rcut, etc..")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0wdja70l7y1cj1d0sijm0q0cbics8xd9wqka7zyb29y1cc57pasa"))))
+                "02zn79l7y7rvy7b6bimlf5qymrvzc43w8q7l4jx3k8wzn2g5326z"))))
     (build-system ocaml-build-system)
     (arguments
      `(#:tests? #f; require odoc