summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-23 17:07:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-23 18:13:29 +0100
commit5d7a6f1ceaa882376b739d5149475565b07e0b94 (patch)
tree84450faf895242895d23cb08e934c3a56de28b32
parentdff0197e604d00ea8c1d96f109de58fa2ed778bf (diff)
downloadguix-5d7a6f1ceaa882376b739d5149475565b07e0b94.tar.gz
gnu: python-mpmath: Use INVOKE.
* gnu/packages/python-xyz.scm (python-mpmath)[arguments]: Unconditionally
return #T in "check" phase.
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cb85565d44..d63f300fde 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5104,8 +5104,7 @@ and statistical routines from scipy and statsmodels.")
      (modify-phases %standard-phases
        (replace 'check
          (lambda _
-           (zero?
-            (system* "python" "mpmath/tests/runtests.py" "-local")))))))
+           (invoke "python" "mpmath/tests/runtests.py" "-local"))))))
   (home-page "http://mpmath.org")
   (synopsis "Arbitrary-precision floating-point arithmetic in python")
   (description