summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-06-12 20:53:19 +0200
committerDavid Craven <david@craven.ch>2016-08-13 14:07:46 +0200
commit60f75c8f21ace819e4b24f99311e5741eafe52cd (patch)
tree358cdda63785cc2497c43ca678e4a340dae1345e
parent39e547f219c68eec7e144dbf7e062511d347c94d (diff)
downloadguix-60f75c8f21ace819e4b24f99311e5741eafe52cd.tar.gz
gnu: kde-frameworks: Add threadweaver.
* gnu/packages/kde-frameworks.scm (threadweaver): New variable.

Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
-rw-r--r--gnu/packages/kde-frameworks.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 7bd44ec5d7..a679c64314 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -968,3 +968,27 @@ system.")
 applications.  It supports several different plugins, including HSpell, Enchant,
 ASpell and HUNSPELL.")
     (license license:lgpl2.1+)))
+
+(define-public threadweaver
+  (package
+    (name "threadweaver")
+    (version "5.24.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "mirror://kde/stable/frameworks/"
+                            (version-major+minor version) "/"
+                            name "-" version ".tar.xz"))
+        (sha256
+         (base32
+          "02g60zr9cc4bg1p90giich4n0qvqaiakz0y94qrnyj9f7fg0yksl"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("qtbase" ,qtbase)))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Helper for multithreaded programming")
+    (description "ThreadWeaver is a helper for multithreaded programming.  It
+uses a job-based interface to queue tasks and execute them in an efficient way.")
+    (license license:lgpl2.1+)))