summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-23 18:37:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-23 18:37:42 +0100
commit6568bd5df24cc43a8b4dffdaccac93c2e893b98a (patch)
tree4acede8cc8c9dd8dd193dc03e772c55c01877fa4
parentc988afda6f2cedb195ea205d8e59c31b5262777e (diff)
downloadguix-6568bd5df24cc43a8b4dffdaccac93c2e893b98a.tar.gz
gnu: python-validictory: Use INVOKE.
* gnu/packages/python-xyz.scm (python-validictory)[arguments]: Unconditionally
return #T from "check" phase.
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 85818c2a2e..47fdd169db 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10429,7 +10429,7 @@ is used by PostgreSQL and the OpenSSH Server for example.")
              (setenv "PYTHONPATH"
                      (string-append (getcwd) "/build/lib:"
                                     (getenv "PYTHONPATH")))
-             (zero? (system* "py.test" "-vv" )))))))
+             (invoke "py.test" "-vv" ))))))
     (native-inputs
      `(("python-pytest" ,python-pytest)))
     (home-page