summary refs log tree commit diff
diff options
context:
space:
mode:
authorpinoaffe <pinoaffe@airmail.cc>2022-02-06 23:24:03 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-02-06 23:24:03 +0100
commit6ad918c0de80d3caaf089d010b47e26101b17c3d (patch)
tree71c2291d92af01a8c1fb35843ef561557d113f3d
parent88299bbe242b9dda0357991d3e8301c413b508e0 (diff)
downloadguix-6ad918c0de80d3caaf089d010b47e26101b17c3d.tar.gz
gnu: Add emacs-enlive.
* gnu/packages/emacs-xyz.scm (emacs-enlive): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 94d050eb8b..de2ac45066 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15492,6 +15492,28 @@ query them from the comfort of your editor.")
 buffer's environment.")
     (license license:gpl3+)))
 
+(define-public emacs-enlive
+  (package
+    (name "emacs-enlive")
+    (version "0.0.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/zweifisch/enlive")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "08j6b79vy8ry4ad1abk3hvxjbb4ylrhkvrbrnq1gcikl4h1p2v63"))))
+    (build-system emacs-build-system)
+    (home-page "http://github.com/zweifisch/enlive")
+    (synopsis "Query HTML document with CSS selectors in Emacs")
+    (description
+     "Enlive is an Emacs library that allows the user to query HTML documents
+from within Elisp using a DSL similar to CSS selectors.")
+    (license license:gpl3+)))
+
 (define-public emacs-envrc
   (package
     (name "emacs-envrc")