summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-15 17:07:44 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-15 17:08:32 +0300
commit6e38ec447f98383e0722ac300734f8d7c8c5c7b0 (patch)
tree1c6304cec0b9011a1299e7290a5e9900d932abec
parentbcda49b656f5320ff3646decdb241e228c8636fd (diff)
downloadguix-6e38ec447f98383e0722ac300734f8d7c8c5c7b0.tar.gz
gnu: vulkan-loader: Limit tests to x86_64 and i686.
* gnu/packages/vulkan.scm (vulkan-loader)[arguments]: Only run the tests
when building on x86_64-linux or i686-linux.
-rw-r--r--gnu/packages/vulkan.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/vulkan.scm b/gnu/packages/vulkan.scm
index b0d968938b..1d2e58f1d4 100644
--- a/gnu/packages/vulkan.scm
+++ b/gnu/packages/vulkan.scm
@@ -228,8 +228,10 @@ interpretation of the specifications for these languages.")
     (build-system cmake-build-system)
     (arguments
      (list
-      #:tests? (not (or (%current-target-system)
-                        (target-riscv64?)))
+      ;; As many as 23 tests are expected to fail per architecture.
+      ;; Limit the tests to those architectures tested upstream.
+      #:tests? (and (%current-system)
+                    (target-x86?))
       #:configure-flags
       #~(list (string-append "-DVULKAN_HEADERS_INSTALL_DIR="
                              (dirname (dirname