summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2023-02-26 01:00:00 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2023-02-26 01:00:07 +0100
commit73cb232442a50aa00104ad739db93f44df9de073 (patch)
treeb9684c20bb765ac335a9940394f06172ca595256
parentcd2293294595215f2adadc11a993486233b9ea3c (diff)
downloadguix-73cb232442a50aa00104ad739db93f44df9de073.tar.gz
gnu: linux-libre-documentation: Honour ‘--cores’.
* gnu/packages/linux.scm (linux-libre-documentation)[arguments]:
Respect PARALLEL-BUILD? and PARALLEL-JOB-COUNT.
-rw-r--r--gnu/packages/linux.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3601744c51..3ca2a79666 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1852,11 +1852,14 @@ GnuPG-based password manager like @code{pass}.")
       #:phases #~(modify-phases %standard-phases
                    (delete 'configure)
                    (replace 'build
-                     (lambda _
+                     (lambda* (#:key parallel-build? #:allow-other-keys)
                        (substitute* "Documentation/Makefile"
                          ;; Remove problematic environment check script.
                          ((".*scripts/sphinx-pre-install.*") ""))
-                       (invoke "make" "infodocs")))
+                       (invoke "make" "infodocs"
+                               "-j" (if parallel-build?
+                                        (number->string (parallel-job-count))
+                                        "1"))))
                    (replace 'install
                      (lambda _
                        (let* ((info-dir (string-append #$output "/share/info"))