summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-06-27 19:29:36 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-17 04:11:53 +0200
commit8226c928c01dadffc7e0baf28856ef7551a1efaa (patch)
tree9b923a450ad93ed5c9539dc6d48a9f7240f92b16
parentcfcb2599108e61f6562070ee1620b2b8e51307c8 (diff)
downloadguix-8226c928c01dadffc7e0baf28856ef7551a1efaa.tar.gz
gnu: Add maven-parent-pom-22.
* gnu/packages/maven-parent-pom.scm (maven-parent-pom-22): New variable.
-rw-r--r--gnu/packages/maven-parent-pom.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/maven-parent-pom.scm b/gnu/packages/maven-parent-pom.scm
index c40d75a4ea..ef59fcf89e 100644
--- a/gnu/packages/maven-parent-pom.scm
+++ b/gnu/packages/maven-parent-pom.scm
@@ -446,3 +446,22 @@ tool.  This package contains the Maven parent POM.")
           `(modify-phases ,phases
              (delete 'install-plugins)
              (delete 'install-shared))))))))
+
+(define-public maven-parent-pom-22
+  (let ((base (make-maven-parent-pom
+                "22" "1kgqbyx7ckashy47n9rgyg4asyrvp933hdiknvnad7msq5d4c2jg"
+                apache-parent-pom-11)))
+    (package
+      (inherit base)
+      (arguments
+       (substitute-keyword-arguments (package-arguments base)
+         ((#:phases phases)
+          `(modify-phases ,phases
+             (delete 'install-plugins)
+             (delete 'install-shared)
+             (add-before 'install 'fix-versions
+               (lambda _
+                 (substitute* "pom.xml"
+                   (("1.5.5")
+                    ,(package-version java-plexus-component-annotations)))
+                 #t)))))))))