summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-08 23:49:30 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-14 20:15:28 +0200
commit85baeb20023acc8e94b2ce9f0b2a12922103bc9d (patch)
tree3126bbc9099201b8f0b49d608c3c28158dc62372
parent10bcd4bb956c09dd13d9296b12c0ee382175976a (diff)
downloadguix-85baeb20023acc8e94b2ce9f0b2a12922103bc9d.tar.gz
gnu: mupen64plus-video-z64: Don't use unstable tarball.
* gnu/packages/emulators.scm (mupen64plus-video-z64)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/emulators.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/emulators.scm b/gnu/packages/emulators.scm
index a22bc49bac..f9358c7225 100644
--- a/gnu/packages/emulators.scm
+++ b/gnu/packages/emulators.scm
@@ -887,13 +887,13 @@ Rice Video plugin.")
     (version "2.0.0")
     (source
      (origin
-       (method url-fetch)
-       (uri (string-append
-             "https://github.com/mupen64plus/mupen64plus-video-z64/archive/"
-             version ".tar.gz"))
-       (file-name (string-append name "-" version ".tar.gz"))
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/mupen64plus/mupen64plus-video-z64.git")
+             (commit version)))
+       (file-name (git-file-name name version))
        (sha256
-        (base32 "1x7wsjs5gx2iwx20p4cjcbf696zsjlh31qxmghwv0ifrq8x58s1b"))
+        (base32 "04qa2fdd6dakpk2v0d4l80xh9b4h8gm71g80c0wyyxdhmhwk1r9c"))
        (patches (search-patches "mupen64plus-video-z64-glew-correct-path.patch"))))
     (build-system gnu-build-system)
     (native-inputs