summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-10 22:25:07 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-13 11:50:49 +0100
commit86825f7f85f91ff648416fea2198d8d36ea54c7f (patch)
tree9c30386b731607408325d872591d0ac69a931ae2
parente283e368902e4b5863318537ee3f995c6ab0b66d (diff)
downloadguix-86825f7f85f91ff648416fea2198d8d36ea54c7f.tar.gz
gnu: Add rust-imgref-1.
* gnu/packages/crates-graphics.scm (rust-imgref-1): New variable.
-rw-r--r--gnu/packages/crates-graphics.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 3467124805..baf6df99c8 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -1251,6 +1251,26 @@ for the most common image formats.")
         ("rust-num-complex" ,rust-num-complex-0.2)
         ("rust-quickcheck" ,rust-quickcheck-0.6))))))
 
+(define-public rust-imgref-1
+  (package
+    (name "rust-imgref")
+    (version "1.7.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "imgref" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "19dd5xss3nd40avv8az2kzicpxx71c2akiqznr616hki30w9vj07"))))
+    (build-system cargo-build-system)
+    (arguments `(#:skip-build? #t))
+    (home-page "https://github.com/kornelski/imgref")
+    (synopsis "2D slice of a @code{Vec}")
+    (description
+     "This package provides a trivial struct for interchange of 2d-dimensional
+pixel buffers with width, height and stride.")
+    (license license:cc0)))
+
 (define-public rust-jpeg-decoder-0.1
   (package
     (name "rust-jpeg-decoder")