summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-11 00:10:49 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-11 00:10:49 +0200
commit8fc86d1f6f220691191091fc21de935699ddd66b (patch)
tree51d9f747aae68d0a26a256a0e82ccb62b908dd85
parent1e841bb8486e904d9ea74af53228c22537021477 (diff)
downloadguix-8fc86d1f6f220691191091fc21de935699ddd66b.tar.gz
gnu: open-adventure: Update to 1.11.
* gnu/packages/games.scm (open-adventure): Update to 1.11.
[arguments]<#:parallel-tests>: Set to #F.
<#:phases>: Fix ECHO filename in an additional file.
-rw-r--r--gnu/packages/games.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 246472c699..e5576fbb1e 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6940,7 +6940,7 @@ at their peak of economic growth and military prowess.
 (define-public open-adventure
   (package
     (name "open-adventure")
-    (version "1.9")
+    (version "1.11")
     (source
      (origin
        (method git-fetch)
@@ -6949,16 +6949,17 @@ at their peak of economic growth and military prowess.
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "123svzy7xczdklx6plbafp22yv9bcvwfibjk0jv2c9i22dfsr07f"))))
+        (base32 "1n0fzrdlbc6px88qr574ww2q85xk43bv09jpmsskzv1l2cncwm37"))))
     (build-system gnu-build-system)
     (arguments
      `(#:make-flags (list "CC=gcc")
+       #:parallel-tests? #f             ;some tests fail non-deterministically
        #:phases
        (modify-phases %standard-phases
          (delete 'configure)            ;no configure script
          (add-before 'build 'use-echo
            (lambda _
-             (substitute* "tests/Makefile"
+             (substitute* (list "tests/Makefile" "tests/tapview")
                (("/bin/echo") (which "echo")))
              #t))
          (add-after 'build 'build-manpage