summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2015-12-24 13:43:32 +0100
committerRicardo Wurmus <rekado@elephly.net>2015-12-24 19:39:17 +0100
commit96250294012c2f1520b67f12ea80bfd6b98075a2 (patch)
treecdce8883b40c361a0957c40535bf9d3fff2d84fc
parent398abcf81a9cede6d073bde01a1cfe9171e06167 (diff)
downloadguix-96250294012c2f1520b67f12ea80bfd6b98075a2.tar.gz
gnu: Add Bristol.
* gnu/packages/music.scm (bristol): New variable.
-rw-r--r--gnu/packages/music.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index 7d243f579e..3787576aea 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -645,6 +645,38 @@ modification devices that brought world-wide fame to the names and products of
 Laurens Hammond and Don Leslie.")
     (license license:gpl2+)))
 
+(define-public bristol
+  (package
+    (name "bristol")
+    (version "0.60.11")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/bristol/bristol/"
+                                  (version-major+minor version)
+                                  "/bristol-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1fi2m4gmvxdi260821y09lxsimq82yv4k5bbgk3kyc3x1nyhn7vx"))))
+    (build-system gnu-build-system)
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("jack" ,jack-1)
+       ("liblo" ,liblo)
+       ("libx11" ,libx11)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (home-page "http://bristol.sourceforge.net/")
+    (synopsis "Synthesizer emulator")
+    (description
+     "Bristol is an emulation package for a number of different 'classic'
+synthesizers including additive and subtractive and a few organs.  The
+application consists of the engine, which is called bristol, and its own GUI
+library called brighton that represents all the emulations.  There are
+currently more than twenty different emulations; each does sound different
+although the author maintains that the quality and accuracy of each emulation
+is subjective.")
+    (license license:gpl3+)))
+
 (define-public tuxguitar
   (package
     (name "tuxguitar")