summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2023-02-18 20:31:27 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-02-18 21:11:56 +0100
commit971778f20b3ce5a5836ed43e238ea43b67909050 (patch)
tree412e48972c6c273227f4a06c92bf2fae9f57e902
parent206195d4e24628739871b837d9986fb827c20086 (diff)
downloadguix-971778f20b3ce5a5836ed43e238ea43b67909050.tar.gz
gnu: Add r-effsize.
* gnu/packages/cran.scm (r-effsize): New variable.
-rw-r--r--gnu/packages/cran.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 52d109ca93..3eb1d1dc42 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14265,6 +14265,27 @@ standardized parameters for a wide variety of models, allowing computation and
 conversion of indices such as Cohen's d, r, odds, etc.")
     (license license:gpl3)))
 
+(define-public r-effsize
+  (package
+    (name "r-effsize")
+    (version "0.8.1")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "effsize" version))
+              (sha256
+               (base32
+                "1m5ch2g77f4ldbxhzp2ls1pga8hq7ggkz1xs8a90h0s09rj0gd7w"))))
+    (properties `((upstream-name . "effsize")))
+    (build-system r-build-system)
+    (home-page "https://github.com/mtorchiano/effsize/")
+    (synopsis "Efficient effect size computation")
+    (description
+     "This package provides a collection of functions to compute the
+standardized effect sizes for experiments (Cohen d, Hedges g, Cliff delta,
+Vargha-Delaney A).  The computation algorithms have been optimized to allow
+efficient computation even with very large data sets.")
+    (license license:gpl2)))
+
 (define-public r-sjplot
   (package
     (name "r-sjplot")