summary refs log tree commit diff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-24 23:07:25 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-01-24 23:07:25 +0100
commit9abac0d338794b1906bb8c73c762648ffdbde121 (patch)
treead968df52d61459143e3990e30b4f47a9aad5814
parent486e79790e59fecd5b4625395f20c995e9b8ab71 (diff)
downloadguix-9abac0d338794b1906bb8c73c762648ffdbde121.tar.gz
gnu: Add emacs-repology.
* gnu/packages/emacs-xyz.scm (emacs-repology): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 163eb6791b..a9e4f69bc0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -21164,6 +21164,25 @@ with emacs.  It displays the output of the @code{repo status} command in a
 buffer and launches Magit from the status buffer for the project at point.")
     (license license:gpl3+)))
 
+(define-public emacs-repology
+  (package
+    (name "emacs-repology")
+    (version "1.0.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://elpa.gnu.org/packages/"
+                           "repology-" version ".tar"))
+       (sha256
+        (base32 "0y12496wafx95izah8vvv1x86k1m8kysm5mlhvshkp0zbpvmb5iq"))))
+    (build-system emacs-build-system)
+    (home-page "https://elpa.gnu.org/packages/repology.html")
+    (synopsis "Repology API access via Elisp")
+    (description
+     "This package provides tools to query Repology API (see
+@url{https://repology.org/api}), process results, and display them.")
+    (license license:gpl3+)))
+
 (define-public emacs-alect-themes
   (package
     (name "emacs-alect-themes")