summary refs log tree commit diff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2021-03-08 18:57:54 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-03-12 14:45:53 +0100
commita35ea5fed953df46cb33e517487e0eac528ec027 (patch)
treec57e59deba8fb3e83168be27cfff1872a099a72a
parent323aec6ad970c0028e43912130c4615fe1e0e537 (diff)
downloadguix-a35ea5fed953df46cb33e517487e0eac528ec027.tar.gz
gnu: r-genefilter: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-genefilter): Move from here...
* gnu/packages/bioconductor.scm (r-genefilter): ...to here.
-rw-r--r--gnu/packages/bioconductor.scm28
-rw-r--r--gnu/packages/bioinformatics.scm28
2 files changed, 28 insertions, 28 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ae8bae4bd9..f6f7766b49 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1487,6 +1487,34 @@ structure.")
 microarrays.")
     (license license:artistic2.0)))
 
+(define-public r-genefilter
+  (package
+    (name "r-genefilter")
+    (version "1.72.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (bioconductor-uri "genefilter" version))
+       (sha256
+        (base32
+         "1c6h3qnjvphs977qhv5vafvsb108r0q7xhaayly6qv6adqfn94rn"))))
+    (build-system r-build-system)
+    (native-inputs
+     `(("gfortran" ,gfortran)
+       ("r-knitr" ,r-knitr)))
+    (propagated-inputs
+     `(("r-annotate" ,r-annotate)
+       ("r-annotationdbi" ,r-annotationdbi)
+       ("r-biobase" ,r-biobase)
+       ("r-biocgenerics" ,r-biocgenerics)
+       ("r-survival" ,r-survival)))
+    (home-page "https://bioconductor.org/packages/genefilter")
+    (synopsis "Filter genes from high-throughput experiments")
+    (description
+     "This package provides basic functions for filtering genes from
+high-throughput sequencing experiments.")
+    (license license:artistic2.0)))
+
 (define-public r-hpar
   (package
     (name "r-hpar")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b258b796f7..557961b664 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -7387,34 +7387,6 @@ includes software to
 ")
       (license license:cc0))))
 
-(define-public r-genefilter
-  (package
-    (name "r-genefilter")
-    (version "1.72.1")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (bioconductor-uri "genefilter" version))
-       (sha256
-        (base32
-         "1c6h3qnjvphs977qhv5vafvsb108r0q7xhaayly6qv6adqfn94rn"))))
-    (build-system r-build-system)
-    (native-inputs
-     `(("gfortran" ,gfortran)
-       ("r-knitr" ,r-knitr)))
-    (propagated-inputs
-     `(("r-annotate" ,r-annotate)
-       ("r-annotationdbi" ,r-annotationdbi)
-       ("r-biobase" ,r-biobase)
-       ("r-biocgenerics" ,r-biocgenerics)
-       ("r-survival" ,r-survival)))
-    (home-page "https://bioconductor.org/packages/genefilter")
-    (synopsis "Filter genes from high-throughput experiments")
-    (description
-     "This package provides basic functions for filtering genes from
-high-throughput sequencing experiments.")
-    (license license:artistic2.0)))
-
 (define-public r-deseq2
   (package
     (name "r-deseq2")