summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-13 14:43:57 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:13 +0100
commitae92caddc5a292b31bb7fc6e4e7c974880f482c0 (patch)
treee85351985056791d3991f1ff3a7c329cb78697fa
parent69866690128615bea022080138d91da4789948db (diff)
downloadguix-ae92caddc5a292b31bb7fc6e4e7c974880f482c0.tar.gz
gnu: python-fixture: Correct inputs.
python-pbr is required only for building.

* gnu/packages/python.scm (python-fixtures) [propagated-inputs] move
  python-pbr-0.11 to [native-inputs].
-rw-r--r--gnu/packages/python.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 13bc5ff43b..8d1acb343b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2056,10 +2056,9 @@ and sensible default behaviors into your setuptools run.")
          "0djxvdwm8s60dbfn7bhf40x6g818p3b3mlwijm1c3bqg7msn271y"))))
     (build-system python-build-system)
     (propagated-inputs
-     `(("python-six" ,python-six)
-       ("python-pbr-0.11" ,python-pbr-0.11)))
+     `(("python-six" ,python-six)))
     (native-inputs
-     `(;; Tests
+     `(("python-pbr-0.11" ,python-pbr-0.11)
        ("python-testtools" ,python-testtools)))
     (arguments
      '(#:tests? #f)) ; no setup.py test command