summary refs log tree commit diff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-01-27 09:28:26 +0100
committerLudovic Courtès <ludo@gnu.org>2022-06-22 12:35:46 +0200
commitb2fab0724d87bd5f798084b95a27768ec7d134da (patch)
treeec2e67d8bb629b987abdf7bbbc02263e5e5a9e82
parent3cac14391bb724dc22b652eb284184f1fde512df (diff)
downloadguix-b2fab0724d87bd5f798084b95a27768ec7d134da.tar.gz
gnu: cagebreak: Update to 1.8.3.
* gnu/packages/wm.scm (cagebreak): Update to 1.8.3.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/wm.scm19
1 files changed, 12 insertions, 7 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 123e6ca7e7..7121b521ab 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2491,7 +2491,7 @@ shows a notification for the user on the screen.")
 (define-public cagebreak
   (package
     (name "cagebreak")
-    (version "1.8.0")
+    (version "1.8.3")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -2500,13 +2500,18 @@ shows a notification for the user on the screen.")
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "0296mnzk7qd0zvnhw716jvpp7madjsar373ixx4qcff0m0jwfrxm"))))
+                "0vm97ak0589v39m3fljf1qhy92dqgiqcrrfp757gg7q58qwa6dkf"))))
     (build-system meson-build-system)
-    (arguments '(#:configure-flags '("-Dxwayland=true")))
-    (native-inputs
-     (list pandoc pkg-config))
-    (inputs
-     (list libevdev pango wlroots))
+    (arguments
+     `(#:configure-flags '("-Dxwayland=true")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-data-dir
+           (lambda* (#:key outputs #:allow-other-keys)
+             (substitute* "meson.build"
+               (("/etc/") (string-append (assoc-ref outputs "out") "/etc"))))))))
+    (native-inputs (list pandoc pkg-config))
+    (inputs (list libevdev pango wlroots))
     (home-page "https://github.com/project-repo/cagebreak")
     (synopsis "Tiling wayland compositor inspired by ratpoison")
     (description