summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-10-02 14:13:56 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-15 22:31:07 +0100
commitb3e8b4bd0f390784c710944c9962a0e13b25ed02 (patch)
treef299c8dab521cd758d379390cb0639ba9280af8e
parentf2516de2fc7459d8ceed1779f0f24840075d08d6 (diff)
downloadguix-b3e8b4bd0f390784c710944c9962a0e13b25ed02.tar.gz
gnu: scons: Do not use setuptools for building.
* gnu/packages/python.scm (scons): Set "#:use-setuptools" to #f.
-rw-r--r--gnu/packages/python.scm1
1 files changed, 1 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 35d9021165..2f7ae95fa4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1390,6 +1390,7 @@ syntax.")
     (arguments
      ;; With Python 3.x, fails to build with a syntax error.
      `(#:python ,python-2
+       #:use-setuptools? #f                ; still relies on distutils
        #:tests? #f))                       ; no 'python setup.py test' command
     (home-page "http://scons.org/")
     (synopsis "Software construction tool written in Python")