summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-12-15 19:45:24 +0800
committer宋文武 <iyzsong@gmail.com>2015-12-20 18:59:22 +0800
commitb96c42605ba68377cac5463822a0a8abecd0acf7 (patch)
treefb2b47085b2104e373e01c19ae3245dd06b7dc4f
parent8e1dd04f450aeef8ebdf7e3030ea3961f3beba75 (diff)
downloadguix-b96c42605ba68377cac5463822a0a8abecd0acf7.tar.gz
gnu: Add gnome-bluetooth.
* gnu/packages/gnome.scm (gnome-bluetooth): New variable.
-rw-r--r--gnu/packages/gnome.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index d45a240532..729dd37e9f 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4362,3 +4362,36 @@ providing graphical log-ins and managing local and remote displays.")
      "LibGTop is a library to get system specific data such as CPU and memory
 usage and information about running processes.")
     (license license:gpl2+)))
+
+(define-public gnome-bluetooth
+  (package
+    (name "gnome-bluetooth")
+    (version "3.18.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://gnome/sources/" name "/"
+                                  (version-major+minor version) "/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0jaa9nbygdvcqp9k4p4iy2g8x3684s4x9k5nbcmmm11jdn4mn7f5"))))
+    (build-system glib-or-gtk-build-system)
+    (native-inputs
+     `(("glib:bin" ,glib "bin") ; for gdbus-codegen, etc.
+       ("gobject-introspection" ,gobject-introspection)
+       ("intltool" ,intltool)
+       ("pkg-config" ,pkg-config)
+       ("xmllint" ,libxml2)))
+    (propagated-inputs
+     ;; gnome-bluetooth-1.0.pc refers to all these.
+     `(("gtk+" ,gtk+)
+       ("udev" ,eudev)))
+    (inputs
+     `(("libcanberra" ,libcanberra)
+       ("libnotify" ,libnotify)))
+    (synopsis "GNOME Bluetooth subsystem")
+    (home-page "https://wiki.gnome.org/Projects/GnomeBluetooth")
+    (description
+     "This package contains tools for managing and manipulating Bluetooth
+devices using the GNOME desktop.")
+    (license license:lgpl2.1+)))