summary refs log tree commit diff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2023-05-15 18:16:00 +0800
committer宋文武 <iyzsong@member.fsf.org>2023-05-15 21:31:51 +0800
commitbcda49b656f5320ff3646decdb241e228c8636fd (patch)
tree80604b589e63bf55f475925c2c17e97f585318e8
parent4975a517c8dcfb4a74d171569264b200434f648f (diff)
downloadguix-bcda49b656f5320ff3646decdb241e228c8636fd.tar.gz
gnu: Use dummy linker for '*-elf' systems.
* gnu/packages/bootstrap.scm (glibc-dynamic-linker): Return "no-ld.so" for
systems with a "-elf" suffix.
-rw-r--r--gnu/packages/bootstrap.scm5
1 files changed, 1 insertions, 4 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 9a46f97c81..5f6a3acc83 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -325,14 +325,11 @@ or false to signal an error."
 
      ;; XXX: This one is used bare-bones, without a libc, so add a case
      ;; here just so we can keep going.
-     ((string=? system "arm-elf") "no-ld.so")
      ((string=? system "arm-eabi") "no-ld.so")
-     ((string=? system "xtensa-elf") "no-ld.so")
      ((string=? system "avr") "no-ld.so")
-     ((string=? system "propeller-elf") "no-ld.so")
      ((string=? system "i686-mingw") "no-ld.so")
      ((string=? system "x86_64-mingw") "no-ld.so")
-     ((string=? system "vc4-elf") "no-ld.so")
+     ((string-suffix? "-elf" system) "no-ld.so")
 
      (else (error "dynamic linker name not known for this system"
                   system)))))