summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-30 15:50:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-30 15:50:42 +0200
commitc4a5ce4648f9b5b69849b9d6b1d63367f5ce7aa0 (patch)
treea6d0ed339aeb817ae572f8c3d75b0f3f84fec9d1
parent8f7d7cd05fb79a00221f91de8f612ed947a2c6df (diff)
downloadguix-c4a5ce4648f9b5b69849b9d6b1d63367f5ce7aa0.tar.gz
gnu: Add r-rcppparallel.
* gnu/packages/cran.scm (r-rcppparallel): New variable.
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8d3086a30b..2980020c6f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -8790,6 +8790,29 @@ package provides a minimal R interface by relying on the Rcpp package.")
     ;; hnswlib is released under Version 2.0 of the Apache License.
     (license (list license:gpl3 license:asl2.0))))
 
+(define-public r-rcppparallel
+  (package
+    (name "r-rcppparallel")
+    (version "4.4.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "RcppParallel" version))
+       (sha256
+        (base32
+         "1ym0bzs9g6bsg2lz24fisxxa3gypr6xcvrczn304czmrrag9413s"))))
+    (properties `((upstream-name . "RcppParallel")))
+    (build-system r-build-system)
+    (home-page "http://rcppcore.github.io/RcppParallel")
+    (synopsis "Parallel programming tools for Rcpp")
+    (description
+     "This package provides high level functions for parallel programming with
+Rcpp.  For example, the @code{parallelFor()} function can be used to convert
+the work of a standard serial @code{for} loop into a parallel one and the
+@code{parallelReduce()} function can be used for accumulating aggregates or
+other values.")
+    (license license:gpl2)))
+
 (define-public r-ncdf4
   (package
     (name "r-ncdf4")