summary refs log tree commit diff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-02-11 21:50:36 +0000
committerEfraim Flashner <efraim@flashner.co.il>2023-02-15 19:25:19 +0200
commitc4cd6560d3351827fbce4fdd9c6c8ab095ba792d (patch)
treef8135189bdfbba88b1c620a6273758038e322c2f
parentf5fb40478120f342d9040f39a862d436e4fdb0d6 (diff)
downloadguix-c4cd6560d3351827fbce4fdd9c6c8ab095ba792d.tar.gz
gnu: Add julia-wcs-jll.
* gnu/packages/julia-jll.scm (julia-wcs-jll): New variable.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/julia-jll.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/julia-jll.scm b/gnu/packages/julia-jll.scm
index 77bb3ff3d5..2320b03595 100644
--- a/gnu/packages/julia-jll.scm
+++ b/gnu/packages/julia-jll.scm
@@ -1763,6 +1763,44 @@ build tree Yggdrasil.")
     (description "This package provides a wrapper for the wayland-protocols library.")
     (license license:expat)))
 
+(define-public julia-wcs-jll
+  (package
+    (name "julia-wcs-jll")
+    (version "7.7.0+0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/JuliaBinaryWrappers/WCS_jll.jl")
+             (commit (string-append "WCS-v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "16i9899jwcp5i9mh88rn4b83v3i5v8g1jygixrr0grjnvf5qfvpk"))))
+    (build-system julia-build-system)
+    (arguments
+     '(#:tests? #f  ; no runtests
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'link-depot 'override-binary-path
+           (lambda* (#:key inputs #:allow-other-keys)
+             (map
+              (lambda (wrapper)
+                (substitute* wrapper
+                  (("generate_wrapper_header.*")
+                   (string-append
+                    "generate_wrapper_header(\"WCS\", \""
+                    (assoc-ref inputs "wcslib") "\")\n"))))
+              ;; There's a Julia file for each platform, override them all
+              (find-files "src/wrappers/" "\\.jl$")))))))
+    (inputs
+     (list wcslib))
+    (propagated-inputs
+     (list julia-jllwrappers))
+    (home-page "https://github.com/JuliaBinaryWrappers/WCS_jll.jl")
+    (synopsis "WCS library wrappers")
+    (description "This package provides a wrapper for the wcs library.")
+    (license license:expat)))
+
 (define-public julia-x264-jll
   (package
     (name "julia-x264-jll")