summary refs log tree commit diff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyich@gmail.com>2021-08-18 23:39:20 +0100
committerBrice Waegeneire <brice@waegenei.re>2021-08-26 21:18:38 +0200
commitd1d9206180763f8291c82b1a6240b3640bd4f238 (patch)
tree8b7d3e17d97e027aac06b044264e9883d2c118c8
parent4b51d045a865892f898e758dc9f379ab0f06cd52 (diff)
downloadguix-d1d9206180763f8291c82b1a6240b3640bd4f238.tar.gz
gnu: mc: Update to 4.8.27.
Switched to direct mirror URI to match SSL certificate issuer
(home page does not provide a download link over secure protocols).

While at it added 'release-monitoing-url property to allow
'generic-html updater to fetch latest version from correct location.
Otherwise the only available updater is 'gnu-ftp (which forces downgrade
to ancient 4.6.1 release).

* gnu/packages/mc.scm (mc): Update to 4.8.27. Explicitly set
release-monitoing-url to up to date location.
-rw-r--r--gnu/packages/mc.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/mc.scm b/gnu/packages/mc.scm
index b9dea3b446..e07191e344 100644
--- a/gnu/packages/mc.scm
+++ b/gnu/packages/mc.scm
@@ -38,14 +38,14 @@
 (define-public mc
   (package
     (name "mc")
-    (version "4.8.26")
+    (version "4.8.27")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "https://ftp.midnight-commander.org/mc-"
+      (uri (string-append "https://ftp.osuosl.org/pub/midnightcommander/mc-"
                           version ".tar.xz"))
       (sha256
-       (base32 "09vc2vf6k12a8k5gdss6hcskwfcbyalrkhn65nidkwlm0p2svpn6"))))
+       (base32 "1x2g5ahgzg951y4ldbsgkv8icni2mgh3p2wsds0j16gsbwi5kgii"))))
     (build-system gnu-build-system)
     (native-inputs `(("perl" ,perl)
                      ("pkg-config" ,pkg-config)))
@@ -97,6 +97,8 @@
                (("usr/bin") "/"))
              #t)))))
     (home-page "https://www.midnight-commander.org")
+    (properties
+      `((release-monitoring-url . "https://ftp.osuosl.org/pub/midnightcommander/")))
     (synopsis "Graphical file manager")
     (description
      "GNU Midnight Commander is a command-line file manager laid out in a