summary refs log tree commit diff
diff options
context:
space:
mode:
authorAleksandr Vityazev <avityazev@posteo.org>2022-10-28 09:04:00 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-10-29 23:52:15 +0200
commitd231651696e5eb66895ca446f2e833ec6df4c571 (patch)
tree2b12a6ffd3211d1482ce4d34f4d01e45c043aa3f
parent9ffeec668e28214c9dc92f7605f78f1a0f0db5ed (diff)
downloadguix-d231651696e5eb66895ca446f2e833ec6df4c571.tar.gz
gnu: emacs-tmr: Update arguments and license.
* gnu/packages/emacs-xyz.scm (emacs-trm): [arguments]:
Rename PATCH-FFPLAY phase to PATCH-PATHS and substitute
TMR-SOUND-FILE variable. Add MAKEINFO phase;
[inputs]: Add SOUND-THEME-FREEDESKTOP;
[license]: Add fdl1.3+;
[use-modules]: Add (gnu packages libcanberra).

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 21 insertions, 6 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a10d65d151..3682a2bbe5 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -245,6 +245,7 @@
   #:use-module (gnu packages ocaml)
   #:use-module (gnu packages erlang)
   #:use-module (gnu packages statistics)
+  #:use-module (gnu packages libcanberra)
   #:use-module (guix utils)
   #:use-module (srfi srfi-1)
   #:use-module (ice-9 match))
@@ -14502,21 +14503,35 @@ structure, or any other pattern.")
      (list
       #:phases
       #~(modify-phases %standard-phases
-          (add-after 'unpack 'patch-ffplay
+          (add-after 'unpack 'patch-paths
             (lambda* (#:key inputs #:allow-other-keys)
               (let ((ffplay (search-input-file inputs "/bin/ffplay")))
-                (make-file-writable "tmr.el")
                 (substitute* "tmr.el"
-                  (("\"ffplay")
-                   (string-append "\"" ffplay)))))))))
+                  (("\"ffplay ")
+                   (string-append "\"" ffplay " "))))
+              (emacs-substitute-variables "tmr.el"
+                ("tmr-sound-file"
+                 (search-input-file
+                  inputs
+                  "share/sounds/freedesktop/stereo/alarm-clock-elapsed.oga")))))
+          (add-after 'install 'makeinfo
+            (lambda _
+              (invoke "emacs"
+                      "--batch"
+                      "--eval=(require 'ox-texinfo)"
+                      "--eval=(find-file \"README.org\")"
+                      "--eval=(org-texinfo-export-to-info)")
+              (install-file "tmr.info"
+                            (string-append #$output "/share/info")))))))
     (native-inputs (list texinfo))
-    (inputs (list ffmpeg))
+    (inputs (list ffmpeg sound-theme-freedesktop))
     (home-page "https://protesilaos.com/emacs/tmr/")
     (synopsis "Set timers using a convenient notation")
     (description
      "TMR is an Emacs package that provides facilities for setting timers
 using a convenient notation.")
-    (license license:gpl3+)))
+    (license (list license:gpl3+
+                   license:fdl1.3+)))) ;GFDLv1.3+ for the manual
 
 (define-public emacs-gn-mode
   (package