summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-05-15 21:33:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-05-15 21:33:56 +0300
commitd9c0280d5e9b636c75c315c8b7aad12e84e67570 (patch)
treebeaa211cb79d6fff96c99e908665e51b65a42a47
parent6e38ec447f98383e0722ac300734f8d7c8c5c7b0 (diff)
downloadguix-d9c0280d5e9b636c75c315c8b7aad12e84e67570.tar.gz
gnu: tokyocabinet: Fix building on non-x86 systems.
* gnu/packages/databases.scm (tokyocabinet)[arguments]: Adjust
configure-flags to not enable x86 specific cflags when building for
other architectures.
-rw-r--r--gnu/packages/databases.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 2b4ec5e09a..3eaaf21a8c 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2659,7 +2659,11 @@ database and supports many programming languages.  It is a NoSQL database.")
     (build-system gnu-build-system)
     (arguments
      `(#:configure-flags
-       (list "--enable-pthread" "--enable-off64" "--enable-fastest"
+       (list "--enable-pthread" "--enable-off64"
+             ,@(if (target-x86?)
+                 ;; Enables x86 specific cflags.
+                 '("--enable-fastest")
+                 '())
         (string-append "LDFLAGS=-Wl,-rpath="
                        (assoc-ref %outputs "out") "/lib"))))
     (inputs