summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-18 09:55:04 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-18 10:19:16 +0200
commitdfcf79ac5943c68dc8013aa333add3f881e894aa (patch)
tree87321d93200928440ed3feecf49731a6c30816bf
parentf8ddfb505a51a2c794531e090dd7ee97022d1096 (diff)
downloadguix-dfcf79ac5943c68dc8013aa333add3f881e894aa.tar.gz
gnu: festival: Include default voice.
* gnu/packages/speech.scm (festival)[arguments]: Install default voice.
[native-inputs]: Add default voice.
-rw-r--r--gnu/packages/speech.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/speech.scm b/gnu/packages/speech.scm
index 6c62739ce8..220d542eda 100644
--- a/gnu/packages/speech.scm
+++ b/gnu/packages/speech.scm
@@ -337,7 +337,9 @@ be used by the sighted.")
                (invoke "tar" "--strip-components=1"
                        "-xvf" (assoc-ref inputs "festvox-cmu"))
                (invoke "tar" "--strip-components=1"
-                       "-xf" (assoc-ref inputs "festvox-poslex"))
+                       "-xvf" (assoc-ref inputs "festvox-poslex"))
+               (invoke "tar" "--strip-components=1"
+                       "-xvf" (assoc-ref inputs "default-voice"))
 
                ;; Install Festival
                (let ((bin (string-append out "/bin"))
@@ -420,6 +422,15 @@ be used by the sighted.")
            (sha256
             (base32
              "18wywilxaqwy63lc47p5g5529mpxhslibh1bjij0snxx5mjf7ip7"))))
+       ("default-voice"
+        ,(origin
+           (method url-fetch)
+           (uri (string-append "http://festvox.org/packed/festival/"
+                               (version-major+minor version)
+                               "/voices/festvox_kallpc16k.tar.gz"))
+           (sha256
+            (base32
+             "136hmsyiwnlg2qwa508dy0imf19mzrb5r3dmb2kg8kcyxnslm740"))))
        ("speech-tools"
         ,(origin
            (method url-fetch)