summary refs log tree commit diff
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2023-02-25 16:21:17 +0100
committerAndreas Enge <andreas@enge.fr>2023-02-25 16:21:24 +0100
commite1361d38b710b75be9a85d187683142b80649593 (patch)
tree81885ae144ebb444862072a473bd11373eac4745
parent970d89b9faaf1e9705134c71fa895861dd83463b (diff)
downloadguix-e1361d38b710b75be9a85d187683142b80649593.tar.gz
gnu: python-responses: Update inputs.
* gnu/packages/python-web.scm (python-responses)[propagated-inputs]: Remove
python-cookies and python-six; add python-toml, python-typing-extensions,
and python-urllib3.
[native-inputs]: Remove python-mock.
-rw-r--r--gnu/packages/python-web.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index a32aba5c58..e5358ec5b2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3587,15 +3587,15 @@ Python.")
              (when tests?
                (invoke "pytest" "-v")))))))
     (native-inputs
-     (list python-mock
-           python-pytest
+     (list python-pytest
            python-pytest-asyncio
            python-pytest-httpserver))
     (propagated-inputs
      (list python-requests
-           python-cookies
-           python-six
-           python-types-toml))
+           python-toml
+           python-types-toml
+           python-typing-extensions
+           python-urllib3))
     (home-page "https://github.com/getsentry/responses")
     (synopsis "Utility for mocking out the `requests` Python library")
     (description "A utility library for mocking out the `requests` Python