summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-31 12:22:58 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-31 12:54:48 +0300
commitea03851b019b699d1f48d39cfd7e681d9fbd3991 (patch)
tree6248055ea4c142d0cdfcefbcc5b4c6fc6986b7b3
parent6a2d36c734a5c5ab7e1826ce9372f680c0fe772d (diff)
downloadguix-ea03851b019b699d1f48d39cfd7e681d9fbd3991.tar.gz
gnu: Add julia-mappedarrays.
* gnu/packages/julia-xyz.scm (julia-mappedarrays): New variable.
-rw-r--r--gnu/packages/julia-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index c802c2b0c5..553dbfca7b 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1158,6 +1158,36 @@ expressions.  This includes a template-matching system and code-walking tools
 that let you do deep transformations of code.")
     (license license:expat)))
 
+(define-public julia-mappedarrays
+  (package
+    (name "julia-mappedarrays")
+    (version "0.4.0")
+    (source
+      (origin
+        (method git-fetch)
+        (uri (git-reference
+               (url "https://github.com/JuliaArrays/MappedArrays.jl")
+               (commit (string-append "v" version))))
+        (file-name (git-file-name name version))
+        (sha256
+         (base32 "0l5adird8m1cmnsxwhzi5hcr7q9bm1rf7a6018zc7kcn2yxdshy3"))))
+    (build-system julia-build-system)
+    (propagated-inputs
+     `(("julia-fixedpointnumbers" ,julia-fixedpointnumbers)))
+    (native-inputs
+     `(("julia-colortypes" ,julia-colortypes)
+       ("julia-fixedpointnumbers" ,julia-fixedpointnumbers)
+       ("julia-offsetarrays" ,julia-offsetarrays)))
+    (home-page "https://github.com/JuliaArrays/MappedArrays.jl")
+    (synopsis "Lazy in-place transformations of arrays")
+    (description "This package implements \"lazy\" in-place elementwise
+transformations of arrays for the Julia programming language.  Explicitly, it
+provides a \"view\" M of an array A so that @code{M[i] = f(A[i])} for a
+specified (but arbitrary) function f, without ever having to compute M
+explicitly (in the sense of allocating storage for M).  The name of the package
+comes from the fact that @code{M == map(f, A)}.")
+    (license license:expat)))
+
 (define-public julia-matrixfactorizations
   (package
     (name "julia-matrixfactorizations")