summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2022-12-13 13:41:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-12-13 14:38:12 +0100
commitf764947dab1b540cea30d9299e3b58ea622c5e8e (patch)
tree1c9612c70842711a751851ce7a516ebd7a74d02f
parentc978ae3c6b8cc1c719f7caa59beee75863f4bda3 (diff)
downloadguix-f764947dab1b540cea30d9299e3b58ea622c5e8e.tar.gz
gnu: kaldi: Remove trailing #T from build phases.
* gnu/packages/machine-learning.scm (kaldi)[arguments]: Remove trailing #T
from build phases.
-rw-r--r--gnu/packages/machine-learning.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index 72458c3f66..f878cc8a36 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -1625,7 +1625,7 @@ discrete, and conditional dimensions.")
          #:phases
          (modify-phases %standard-phases
            (add-after 'unpack 'chdir
-             (lambda _ (chdir "src") #t))
+             (lambda _ (chdir "src")))
            (replace 'configure
              (lambda* (#:key build system inputs outputs #:allow-other-keys)
                (when (not (or (string-prefix? "x86_64" system)
@@ -1671,8 +1671,7 @@ discrete, and conditional dimensions.")
                (invoke "make" "-C" "onlinebin" "depend")
                (invoke "make" "-C" "onlinebin")
                (invoke "make" "-C" "gst-plugin" "depend")
-               (invoke "make" "-C" "gst-plugin")
-               #t))
+               (invoke "make" "-C" "gst-plugin")))
            ;; TODO: also install the executables.
            (replace 'install
              (lambda* (#:key outputs #:allow-other-keys)
@@ -1693,8 +1692,7 @@ discrete, and conditional dimensions.")
                                (install-file file target-dir)))
                            (find-files "." "\\.h"))
                  (install-file "gst-plugin/libgstonlinegmmdecodefaster.so"
-                               (string-append lib "/gstreamer-1.0"))
-                 #t))))))
+                               (string-append lib "/gstreamer-1.0"))))))))
       (inputs
        (list alsa-lib
              `(,gfortran "lib")