summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-07-28 16:40:16 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-10-07 10:11:11 -0400
commitff33b8698a17af3f8b079b03b83243fba4bd5d88 (patch)
treeef40fba18983c65313403e4f16017cc42d7034f5
parenta7bfc9d68f0dc5775df53fb6e5c81c6a1b3b5dcd (diff)
downloadguix-ff33b8698a17af3f8b079b03b83243fba4bd5d88.tar.gz
gnu: tigervnc-server: Disable tests via #:tests?.
* gnu/packages/vnc.scm (tigervnc-server)
[tests?]: Set to #f.
[phases]: Restore check phase.
-rw-r--r--gnu/packages/vnc.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/vnc.scm b/gnu/packages/vnc.scm
index 4795ccc72a..3731f63846 100644
--- a/gnu/packages/vnc.scm
+++ b/gnu/packages/vnc.scm
@@ -256,6 +256,8 @@ application which is needed to connect to VNC servers.")
     (arguments
      (substitute-keyword-arguments
          (package-arguments xorg-server)
+       ((#:tests? #f #f)
+        #f)
        ((#:configure-flags flags)
         #~(cons* "--with-pic"           ; Taken from BUILDING.txt
                  "--without-dtrace"
@@ -282,7 +284,6 @@ application which is needed to connect to VNC servers.")
                  modules))
        ((#:phases phases)
         #~(modify-phases #$phases
-            (delete 'check)             ;no test suite
             (add-after 'unpack 'adjust-pam-config
               (lambda _
                 (substitute* "tigervnc-client/unix/vncserver/tigervnc.pam"