summary refs log tree commit diff
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-01-19 19:54:59 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-01-20 15:38:03 +0100
commite431eb670dd3d367385f995197f0d1cce11ce970 (patch)
tree9aed50fac0f9ad571a38376793fd08fa9ade966b
parent793f2edbbc572e83612cb9ac5a7f685d46216cd4 (diff)
downloadguix-e431eb670dd3d367385f995197f0d1cce11ce970.tar.gz
gnu: Add r-fastica.
* gnu/packages/statistics.scm (r-fastica): New variable.
-rw-r--r--gnu/packages/statistics.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index b4f8152b28..f27cb57042 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4123,3 +4123,24 @@ for a given problem at the cost of a single least squares fit.  Another LARS
 modification efficiently implements epsilon Forward Stagewise linear
 regression.")
     (license license:gpl2)))
+
+(define-public r-fastica
+  (package
+    (name "r-fastica")
+    (version "1.2-0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "fastICA" version))
+       (sha256
+        (base32
+         "0ykk78fsk5da2g16i4wji85bvji7nayjvkfp07hyaxq9d15jmf0r"))))
+    (properties `((upstream-name . "fastICA")))
+    (build-system r-build-system)
+    (home-page "http://cran.r-project.org/web/packages/fastICA")
+    (synopsis "FastICA algorithms to perform ICA and projection pursuit")
+    (description
+     "This package provides an implementation of the FastICA algorithm to
+perform @dfn{independent component analysis} (ICA) and projection pursuit.")
+    ;; Any GPL version.
+    (license license:gpl3+)))