summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-16 10:37:49 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 17:08:13 +0200
commit11284cb3218727c36060aa2df1eba8ffe0b69a19 (patch)
tree0f9b831e31af0a2d00ddf62b09fa2b11206e4f62
parentb4bf509785acab8e5785299ace09d422c3b19186 (diff)
downloadguix-11284cb3218727c36060aa2df1eba8ffe0b69a19.tar.gz
gnu: gfortran: Remove obsolete workaround.
* gnu/packages/gcc.scm (gfortran): Use GCC directly.
-rw-r--r--gnu/packages/gcc.scm7
1 files changed, 1 insertions, 6 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 8362c9fac1..6eead029cd 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -734,12 +734,7 @@ as the 'native-search-paths' field."
 
 (define-public gfortran
   (hidden-package
-   (custom-gcc (package
-                 (inherit gcc)
-                 ;; XXX: Remove LIBSTDC++-HEADERS from the inputs just to
-                 ;; avoid a rebuild of all the GFORTRAN dependents.
-                 ;; TODO: Remove this hack on the next rebuild cycle.
-                 (inputs (alist-delete "libstdc++" (package-inputs gcc))))
+   (custom-gcc gcc
                "gfortran" '("fortran")
                %generic-search-paths)))