summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-16 11:33:32 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 17:08:14 +0200
commit1496bb5c102bee51c3ab4d0b9ec750f652f2c1fd (patch)
treec857bd10c0c5fdc6e769ee470f72cc4367e5e737
parentb08d989045450c72260e3781ef458555b9e2597c (diff)
downloadguix-1496bb5c102bee51c3ab4d0b9ec750f652f2c1fd.tar.gz
gnu: autoconf: Remove unnecessary conditional.
* gnu/packages/autotools.scm (autoconf-2.69)[inputs]: Add all
unconditionally.
-rw-r--r--gnu/packages/autotools.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/autotools.scm b/gnu/packages/autotools.scm
index 8c593c5208..e9935099e3 100644
--- a/gnu/packages/autotools.scm
+++ b/gnu/packages/autotools.scm
@@ -59,12 +59,9 @@
         "113nlmidxy9kjr45kg9x3ngar4951mvag1js2a3j8nxcz34wxsv4"))))
     (build-system gnu-build-system)
     (inputs
-     ;; TODO: remove `if' in the next rebuild cycle.
-     (if (%current-target-system)
-         `(("bash" ,bash-minimal)
-           ("perl" ,perl)
-           ("m4" ,m4))
-         '()))
+     `(("bash" ,bash-minimal)
+       ("perl" ,perl)
+       ("m4" ,m4)))
     (native-inputs
      `(("perl" ,perl)
        ("m4" ,m4)))