summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-21 15:04:09 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-21 15:16:11 +0100
commit2af29d239b8f98e088fa775d2c5abb526931dac9 (patch)
treeac57cb2171f85810ec93472af227f3610ce3e3d6
parentb1fb4b23712d71363355e4cec9eb16e8e8cfcabd (diff)
downloadguix-2af29d239b8f98e088fa775d2c5abb526931dac9.tar.gz
gnu: perf: Install libraries to lib/ instead of lib64/.
* gnu/packages/linux.scm (perf)[arguments]: Add "lib=lib" to
  #:make-flags.
-rw-r--r--gnu/packages/linux.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index de39f3262b..d4405ac5d1 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1709,7 +1709,11 @@ in a digital read-out.")
                  %standard-phases)
        #:make-flags (list (string-append "DESTDIR="
                                          (assoc-ref %outputs "out"))
-                          "WERROR=0")
+                          "WERROR=0"
+
+                          ;; By default, 'config/Makefile' uses lib64 on
+                          ;; x86_64.  Work around that.
+                          "lib=lib")
        #:tests? #f))                              ;no tests
     (native-inputs
      `(("pkg-config" ,pkg-config)