summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-20 12:14:56 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-20 15:21:24 +0100
commit2c84ba7e11c58d2407df895635d9524ecdd0b626 (patch)
treecd2afbc70dad53d65ed0d4923285d59ecd33b5fc
parent4f2a52aeb5aa686b4801b6fa1821817c4a74f563 (diff)
downloadguix-2c84ba7e11c58d2407df895635d9524ecdd0b626.tar.gz
gnu: Add ruby-net-ssh.
* gnu/packages/ruby.scm (ruby-net-ssh): New variable.
-rw-r--r--gnu/packages/ruby.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 981b0ca951..7c1242123e 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1311,6 +1311,27 @@ allows mocking and stubbing of methods on real (non-mock) classes.")
     (home-page "http://gofreerange.com/mocha/docs")
     (license license:expat)))
 
+(define-public ruby-net-ssh
+  (package
+    (name "ruby-net-ssh")
+    (version "3.0.1")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "net-ssh" version))
+              (sha256
+               (base32
+                "1dzqkgwi9xm6mbfk1rkk17rzmz8m5xakqi21w1b97ybng6kkw0hf"))))
+    (build-system ruby-build-system)
+    (native-inputs
+     `(("ruby-mocha" ,ruby-mocha)
+       ("ruby-test-unit" ,ruby-test-unit)))
+    (synopsis "Ruby implementation of the SSH2 client protocol")
+    (description "@code{Net::SSH} is a pure-Ruby implementation of the SSH2
+client protocol.  It allows you to write programs that invoke and interact
+with processes on remote servers, via SSH2.")
+    (home-page "https://github.com/net-ssh/net-ssh")
+    (license license:expat)))
+
 (define-public ruby-minitest
   (package
     (name "ruby-minitest")