summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-05-16 11:50:25 +0200
committerMarius Bakke <marius@gnu.org>2021-05-22 17:08:14 +0200
commit4119775de1aef44104186b3abfba1973aa973b1a (patch)
tree3409091c8bc85f139d08b15357b569bdf60550f8
parent46f2d25b0907bb7f9e898686508fdee02f4a4753 (diff)
downloadguix-4119775de1aef44104186b3abfba1973aa973b1a.tar.gz
gnu: libuv: Update to 1.41.0.
* gnu/packages/libevent.scm (libuv): Update to 1.41.0.
[native-inputs]: Change from AUTOCONF-WRAPPER to AUTOCONF.
-rw-r--r--gnu/packages/libevent.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 098fd0b9ba..0fa2b5b146 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -103,21 +103,20 @@ limited support for fork events.")
 (define-public libuv
   (package
     (name "libuv")
-    (version "1.38.1")
+    (version "1.41.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://dist.libuv.org/dist/v" version
                                   "/libuv-v" version ".tar.gz"))
               (sha256
                (base32
-                "0iy6yp9nrxpj643w7la3kl3j59ni59b0l4v6n23a63s8kqkpvkhf"))))
+                "0vpbssrbkxzz0gizxxvz5262h9gyn2msac6d1nfavpg10wwm710i"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags '("--disable-static")
        ;; XXX: Some tests want /dev/tty, attempt to make connections, etc.
        #:tests? #f))
-    ;; TODO replace with autoconf on core-updates
-    (native-inputs `(("autoconf" ,autoconf-wrapper)
+    (native-inputs `(("autoconf" ,autoconf)
                      ("automake" ,automake)
                      ("libtool" ,libtool)