summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-03-24 18:01:00 +0000
committerChristopher Baines <mail@cbaines.net>2019-04-14 10:45:57 +0100
commit41c685f51ccb89f6f72d2425d7ae75596894e204 (patch)
treebdcbf161cd80d750f46bd6ead7a760f3a7363c85
parent1b7436aeb5dd13140cb192d6f6617960e1ca911c (diff)
downloadguix-41c685f51ccb89f6f72d2425d7ae75596894e204.tar.gz
gnu: Add perl-http-tinyish.
* gnu/packages/web.scm (perl-http-tinyish): New variable.
-rw-r--r--gnu/packages/web.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index a14b010d47..894fa9beeb 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3010,6 +3010,33 @@ simple requests without the overhead of a large framework like LWP::UserAgent.
 It supports proxies and redirection.  It also correctly resumes after EINTR.")
     (license l:perl-license)))
 
+(define-public perl-http-tinyish
+  (package
+    (name "perl-http-tinyish")
+    (version "0.15")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/M/MI/MIYAGAWA/HTTP-Tinyish-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "199sa722amvwhq0czjfb7psj3hbqmvni5vxkrm579r5943pg0rax"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-file-which" ,perl-file-which)
+       ("perl-ipc-run3" ,perl-ipc-run3)))
+    (home-page "https://metacpan.org/release/HTTP-Tinyish")
+    (synopsis "@code{HTTP::Tiny} compatible HTTP client wrappers")
+    (description
+     "@code{HTTP::Tinyish} is a wrapper module for @acronym{LWP,libwww-perl},
+@code{HTTP::Tiny}, curl and wget.
+
+It provides an API compatible to HTTP::Tiny.")
+    (license l:perl-license)))
+
 (define-public perl-io-html
   (package
     (name "perl-io-html")