summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-09-08 16:01:43 +0200
committerDavid Craven <david@craven.ch>2016-09-13 16:45:41 +0200
commit499fb7e0baf0ec43ef9aac6d663da95415041954 (patch)
treee0456bfcd2ee063cd61cd98d1a67e7e7084847e7
parent6d7ef2aad29679cf5327efc35e241a0a75c7c301 (diff)
downloadguix-499fb7e0baf0ec43ef9aac6d663da95415041954.tar.gz
gnu: linux-libre: Apply %boot-logo patch in origin.
* gnu/packages/linux.scm (linux-libre)[origin]: Apply %boot-logo patch
  in origin.
-rw-r--r--gnu/packages/linux.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 27b5f4a9dc..a7eaae9b39 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -266,7 +266,8 @@ for SYSTEM and optionally VARIANT, or #f if there is no such configuration."
               (uri (linux-libre-urls version))
               (sha256
                (base32
-                "18sy1vh4x66hsk0qbq8g5299my082d530zm8c7xnbakq7350igi6"))))
+                "18sy1vh4x66hsk0qbq8g5299my082d530zm8c7xnbakq7350igi6"))
+              (patches (origin-patches %boot-logo-patch))))
     (build-system gnu-build-system)
     (supported-systems '("x86_64-linux" "i686-linux"))
     (native-inputs
@@ -274,7 +275,6 @@ for SYSTEM and optionally VARIANT, or #f if there is no such configuration."
        ("bc" ,bc)
        ("openssl" ,openssl)
        ("module-init-tools" ,module-init-tools)
-       ("patch/freedo+gnu" ,%boot-logo-patch)
 
        ,@(let ((conf (kernel-config
                       (or (%current-target-system)
@@ -297,10 +297,6 @@ for SYSTEM and optionally VARIANT, or #f if there is no such configuration."
              (setenv "KCONFIG_NOTIMESTAMP" "1")
              (setenv "KBUILD_BUILD_TIMESTAMP" (getenv "SOURCE_DATE_EPOCH"))
 
-             ;; Apply the neat patch.
-             (system* "patch" "-p1" "--force"
-                      "-i" (assoc-ref inputs "patch/freedo+gnu"))
-
              (let ((arch ,(system->linux-architecture
                            (or (%current-target-system)
                                (%current-system)))))