summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-21 20:16:34 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-21 20:17:20 +0100
commit559f37328851fc1ae1d90f27fab7beff3d804421 (patch)
tree1ecf0cda342e829d498c4f39df611fbf9b06a0c8
parentee38d87c58aaf8f8c1b7599a598a56b94f09f711 (diff)
downloadguix-559f37328851fc1ae1d90f27fab7beff3d804421.tar.gz
gnu: Remove qemu-minimal@2.10.
* gnu/packages/virtualization.scm (qemu-minimal-2.10): Remove variable.
-rw-r--r--gnu/packages/virtualization.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index 03f0ceaeee..b7e2c415fe 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -284,34 +284,6 @@ server and embedded PowerPC, and S390 guests.")
                   '("libusb" "mesa" "sdl2" "spice" "virglrenderer" "gtk+"
                     "usbredir" "libdrm" "libepoxy" "pulseaudio" "vde2")))))
 
-;; The GRUB test suite fails with later versions of Qemu, so we
-;; keep it at 2.10 for now.  See
-;; <https://lists.gnu.org/archive/html/bug-grub/2018-02/msg00004.html>.
-;; This package is hidden since we do not backport updates to it.
-(define-public qemu-minimal-2.10
-  (hidden-package
-   (package
-    (inherit qemu-minimal)
-    (version "2.10.2")
-    (source (origin
-             (method url-fetch)
-             (uri (string-append "https://download.qemu.org/qemu-"
-                                 version ".tar.xz"))
-             (sha256
-              (base32
-               "17w21spvaxaidi2am5lpsln8yjpyp2zi3s3gc6nsxj5arlgamzgw"))
-             (patches
-              (search-patches "qemu-glibc-2.27.patch"))))
-    ;; qemu-minimal-2.10 needs Python 2. Remove below once no longer necessary.
-    (native-inputs `(("python-2" ,python-2)
-                     ,@(fold alist-delete (package-native-inputs qemu-minimal)
-                             '("python-wrapper" "python-sphinx"))))
-    (inputs
-     (fold alist-delete (package-inputs qemu-minimal)
-           ;; Disable seccomp support, because it's not required for the GRUB
-           ;; test suite, and because it fails with libseccomp 2.4.2 and later.
-           '("libseccomp"))))))
-
 (define-public libosinfo
   (package
     (name "libosinfo")