summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-11-24 14:06:16 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-11-25 14:05:37 +0100
commit5b720c15d1842b203d133ba46d91749f66ba07cc (patch)
treea03454b1a0ba72b348ad75ab8e5374d1de4bcb13
parent54a8cb963de17663fd41387b23972994354535b8 (diff)
downloadguix-5b720c15d1842b203d133ba46d91749f66ba07cc.tar.gz
gnu: r-pheatmap: Move to (gnu packages cran).
* gnu/packages/statistics.scm (r-pheatmap): Move from here...
* gnu/packages/cran.scm (r-pheatmap): ...to here.
-rw-r--r--gnu/packages/cran.scm23
-rw-r--r--gnu/packages/statistics.scm24
2 files changed, 23 insertions, 24 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 82ff17db07..d6127196a0 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -123,6 +123,29 @@ provides methods for automatically determining breaks and labels for axes and
 legends.")
     (license license:expat)))
 
+(define-public r-pheatmap
+  (package
+    (name "r-pheatmap")
+    (version "1.0.12")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "pheatmap" version))
+       (sha256
+        (base32
+         "1hdh74az3vyzz6dqa311rhxdm74n46lyr03p862kn80p0kp9d7ap"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-gtable" ,r-gtable)
+       ("r-rcolorbrewer" ,r-rcolorbrewer)
+       ("r-scales" ,r-scales)))
+    (home-page "https://cran.r-project.org/web/packages/pheatmap")
+    (synopsis "Pretty heatmaps")
+    (description
+     "This package provides an implementation of heatmaps that offers more
+control over dimensions and appearance.")
+    (license license:gpl2+)))
+
 (define-public r-ellipsis
   (package
     (name "r-ellipsis")
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index ea91126c74..a83e792ef0 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -848,30 +848,6 @@ functions of regression coefficients, and @code{epredict} methods that handle
 non-estimable cases correctly.")
     (license license:gpl2+)))
 
-(define-public r-pheatmap
-  (package
-    (name "r-pheatmap")
-    (version "1.0.12")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (cran-uri "pheatmap" version))
-       (sha256
-        (base32
-         "1hdh74az3vyzz6dqa311rhxdm74n46lyr03p862kn80p0kp9d7ap"))))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-gtable" ,r-gtable)
-       ("r-rcolorbrewer" ,r-rcolorbrewer)
-       ("r-scales" ,r-scales)))
-    (home-page
-     "https://cran.r-project.org/web/packages/pheatmap")
-    (synopsis "Pretty heatmaps")
-    (description
-     "This package provides an implementation of heatmaps that offers more
-control over dimensions and appearance.")
-    (license license:gpl2+)))
-
 (define-public r-labeling
   (package
     (name "r-labeling")