summary refs log tree commit diff
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2019-12-29 07:39:22 +0000
committerVagrant Cascadian <vagrant@debian.org>2019-12-29 01:27:13 -0800
commit5de06b9dfb7e8fa5e32187d6a118cfeb04eff0a3 (patch)
tree968ab543f036a03e7b786dff2d3f8079af054a5c
parentfa9e3b5ed2a16747d719ce49f114ce74d2e8678d (diff)
downloadguix-5de06b9dfb7e8fa5e32187d6a118cfeb04eff0a3.tar.gz
gnu: diffoscope: Update to 134.
* gnu/packages/diffoscope (diffoscope): Update to 134.
  [arguments] Remove phase adding support for zstd.
-rw-r--r--gnu/packages/diffoscope.scm10
1 files changed, 2 insertions, 8 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index 93630f3bb6..a362285051 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -67,7 +67,7 @@
   #:use-module (ice-9 match))
 
 (define-public diffoscope
-  (let ((version "133"))
+  (let ((version "134"))
     (package
       (name "diffoscope")
       (version version)
@@ -79,7 +79,7 @@
                 (file-name (git-file-name name version))
                 (sha256
                  (base32
-                  "0mvg5iyd3zjxsm66vax3qb89214j3wxcklvbhfrr8jlbzaw9pznh"))))
+                  "04078cn3lazcrpgzzzy1s9721hprkylrvfa58izm4dcvgd7a593z"))))
       (build-system python-build-system)
       (arguments
        `(#:phases (modify-phases %standard-phases
@@ -90,12 +90,6 @@
                       (lambda _
                         (substitute* "setup.py"
                           (("'python-magic',") ""))))
-                    ;; Patch in support for known tools
-                    (add-after 'unpack 'add-known-tools
-                      (lambda _
-                        (substitute* "diffoscope/external_tools.py"
-                          (("'debian': 'zstd'")
-                           "'debian': 'zstd', 'guix': 'zstd'"))))
                     ;; This test is broken because our `file` package has a
                     ;; bug in berkeley-db file type detection.
                     (add-after 'unpack 'remove-berkeley-test