summary refs log tree commit diff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-03-24 18:10:33 +0000
committerChristopher Baines <mail@cbaines.net>2019-04-14 10:45:59 +0100
commit709a9e9214901defe68dc9cc82ef045bafaa9dae (patch)
tree515e15a90ba070b22b3966ffdcfe9a3d2e4f305c
parent402cfebf5ce8dbc87d912347436e56af83c88543 (diff)
downloadguix-709a9e9214901defe68dc9cc82ef045bafaa9dae.tar.gz
gnu: Add perl-test-file-contents.
* gnu/packages/perl-check.scm (perl-test-file-contents): New variable.
-rw-r--r--gnu/packages/perl-check.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 2399b073cd..10583822f7 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -572,6 +572,34 @@ testing exception-throwing code with about the same amount of typing.")
 attributes.")
     (license perl-license)))
 
+(define-public perl-test-file-contents
+  (package
+    (name "perl-test-file-contents")
+    (version "0.23")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "mirror://cpan/authors/id/D/DW/DWHEELER/Test-File-Contents-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0g8zgfyw84181snw7ghahnl9r4lrmlfj7zwi76sv8d0bj7xssvyd"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-module-build" ,perl-module-build)))
+    (propagated-inputs
+     `(("perl-test-pod" ,perl-test-pod)
+       ("perl-test-pod-coverage" ,perl-test-pod-coverage)
+       ("perl-text-diff" ,perl-text-diff)))
+    (home-page "https://metacpan.org/release/Test-File-Contents")
+    (synopsis "Test routines for examining the contents of files")
+    (description
+     "@{Test::File::Contents} provides functions for testing the contents of
+files.")
+    (license perl-license)))
+
 (define-public perl-test-file-sharedir-dist
   (package
     (name "perl-test-file-sharedir-dist")