summary refs log tree commit diff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-09-04 22:28:22 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-09-04 23:08:18 +0200
commit8dfe8fee5408c6a4b31866d5e7c073100e3ea285 (patch)
tree7520f23c1be697bfaedb95a3d12a066224e413a1
parentb2f810fe939ca98ee578a55d42f8d939539ae845 (diff)
downloadguix-8dfe8fee5408c6a4b31866d5e7c073100e3ea285.tar.gz
gnu: ocaml-biniou: Update to 1.2.1.
* gnu/packages/ocaml.scm (ocaml-biniou): Update to 1.2.1.
-rw-r--r--gnu/packages/ocaml.scm16
1 files changed, 13 insertions, 3 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 52f7a42e93..0fef79574c 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3540,19 +3540,29 @@ than the first one.")
 (define-public ocaml-biniou
  (package
    (name "ocaml-biniou")
-   (version "1.2.0")
+   (version "1.2.1")
    (home-page "https://github.com/mjambon/biniou")
     (source
      (origin
        (method git-fetch)
        (uri (git-reference
              (url (string-append home-page ".git"))
-             (commit (string-append "v" version))))
+             (commit version)))
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0mjpgwyfq2b2izjw0flmlpvdjgqpq8shs89hxj1np2r50csr8dcb"))))
+         "0x2kiy809n1j0yf32l7hj102y628jp5jdrkbi3z7ld8jq04h1790"))))
    (build-system dune-build-system)
+   (arguments
+    `(#:phases
+      (modify-phases %standard-phases
+        (add-before 'build 'make-writable
+          (lambda _
+            (for-each
+              (lambda (file)
+                (chmod file #o644))
+              (find-files "." "."))
+            #t)))))
    (inputs
     `(("ocaml-easy-format" ,ocaml-easy-format)))
    (native-inputs