summary refs log tree commit diff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2020-06-18 18:22:49 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2020-06-18 18:31:09 +0200
commit8fdd0da49c81366a2061da35739cede3df107e15 (patch)
treed90d93cb24fe3ecc49c1bdb87ea2e3bb2f4ef475
parentf43e4104701340acea0d5504bc26723d7d4cbe08 (diff)
downloadguix-8fdd0da49c81366a2061da35739cede3df107e15.tar.gz
gnu: Add multimon-ng.
* gnu/packages/radio.scm (multimon-ng): New variable.
-rw-r--r--gnu/packages/radio.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index d18af8f75c..a607ad1bae 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1070,3 +1070,41 @@ their position, altitude, speed, etc.")
 from devices on the 433 MHz, 868 MHz, 315 MHz, 345 MHz and 915 MHz ISM bands.")
     (home-page "https://github.com/merbanan/rtl_433")
     (license license:gpl2+)))
+
+(define-public multimon-ng
+  (package
+    (name "multimon-ng")
+    (version "1.1.8")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/EliasOenal/multimon-ng.git")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1973xfyvzl1viz19zr83cgqlx5laxbjrca35rqabn6dlb6xb5xk8"))))
+    (build-system cmake-build-system)
+    (inputs
+     `(("libx11" ,libx11)
+       ("pulseaudio" ,pulseaudio)))
+    (arguments
+     '(#:tests? #f)) ; No test suite
+    (home-page "https://github.com/EliasOenal/multimon-ng")
+    (synopsis "Decoder for digital radio transmission modes")
+    (description "Multimon-ng can decode several digital radio transmission
+modes:
+@itemize
+@item POCSAG512, POCSAG1200, POCSAG2400
+@item FLEX
+@item EAS
+@item UFSK1200, CLIPFSK, AFSK1200, AFSK2400, AFSK2400_2, AFSK2400_3
+@item HAPN4800
+@item FSK9600
+@item DTMF
+@item ZVEI1, ZVEI2, ZVEI3, DZVEI, PZVEI
+@item EEA, EIA, CCIR
+@item MORSE CW
+@item X10
+@end itemize")
+    (license license:gpl2+)))