summary refs log tree commit diff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-01-24 10:50:26 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2021-02-01 11:53:58 -0500
commit905b1b1081500aaea5050bf602337a7f78b1f01c (patch)
treee644984d9860df9f1f906e1177b84d6e6348d3a1
parentcdbe4a7c704ffe1d4bbdb632709f233aab31f942 (diff)
downloadguix-905b1b1081500aaea5050bf602337a7f78b1f01c.tar.gz
gnu: python2-send2trash: Do not set PYTHONPATH.
* gnu/packages/python-xyz.scm (python2-send2trash): Do not override the
arguments field.
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 1 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 135b1e209e..d61a325478 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -17565,17 +17565,7 @@ user's @file{~/Trash} directory.")
     (license license:bsd-3)))
 
 (define-public python2-send2trash
-  (package
-    (inherit (package-with-python2 (strip-python2-variant python-send2trash)))
-    (arguments
-     (substitute-keyword-arguments (package-arguments python-send2trash)
-       ((#:phases phases)
-        `(modify-phases ,phases
-           (add-before 'check 'setenv
-             (lambda _
-               (setenv "PYTHONPATH"
-                       (string-append (getcwd) ":" (getenv "PYTHONPATH")))
-               #t))))))))
+  (package-with-python2 (strip-python2-variant python-send2trash)))
 
 (define-public python-pyfavicon
   (package