summary refs log tree commit diff
diff options
context:
space:
mode:
authorJacob MacDonald <jaccarmac@gmail.com>2019-07-11 15:41:26 -0500
committerLudovic Courtès <ludo@gnu.org>2019-07-13 15:13:53 +0200
commit97f0bd7d68f6845c91c01dffb5181c928db5108f (patch)
tree4cc1b2147b70656dc565bdce93cbb4abfab892e9
parenta76e6a690f290084ff9bf08df416d84463018e3c (diff)
downloadguix-97f0bd7d68f6845c91c01dffb5181c928db5108f.tar.gz
gnu: Add python-requests-2.20.
* gnu/packages/python-web.scm (python-requests-2.20): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-web.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 04f53740e4..72d4eba0ff 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1352,6 +1352,22 @@ WebSocket usage in Python programs.")
 than Python’s urllib2 library.")
     (license license:asl2.0)))
 
+;; Some software requires an older version of Requests, notably Docker/Docker
+;; Compose.
+(define-public python-requests-2.20
+  (package (inherit python-requests)
+           (version "2.20.1")
+           (source (origin
+                     (method url-fetch)
+                     (uri (pypi-uri "requests" version))
+                     (sha256
+                      (base32
+                       "0qzj6cgv3k9wyj7wlxgz7xq0cfg4jbbkfm24pp8dnhczwl31527a"))))
+           (propagated-inputs
+            `(("python-urllib3" ,python-urllib3-1.24)
+              ("python-idna" ,python-idna-2.7)
+              ,@(package-propagated-inputs python-requests)))))
+
 ;; Some software requires an older version of Requests, notably Docker
 ;; Compose.
 (define-public python-requests-2.7