summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-05-20 16:38:41 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-05-20 17:12:25 +0300
commit9f3dae8f61bdc60b699d3361c0dc21f6999203af (patch)
treeb7e40a7cabb35d366fa281249b0e32c90fefcce3
parentc0f5dd63d0510a2c4080dfbad1beb801d649db95 (diff)
downloadguix-9f3dae8f61bdc60b699d3361c0dc21f6999203af.tar.gz
gnu: Add julia-safetestsets.
* gnu/packages/julia-xyz.scm (julia-safetestsets): New variable.
-rw-r--r--gnu/packages/julia-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index 93381d8ff9..ebe7e860d7 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -1423,6 +1423,33 @@ high-order accuracy, assuming that @code{f(x0+h)} has a Taylor series or some
 other power series in @code{h}.")
     (license license:expat)))
 
+(define-public julia-safetestsets
+  ;; The only release tag is the first commit in the repository.
+  (let ((commit "e553edc4c753344d38349304b9ff5483c3b8ff21")
+        (revision "1"))
+    (package
+      (name "julia-safetestsets")
+      (version (git-version "0.0.1" revision commit))
+      (source
+        (origin
+          (method git-fetch)
+          (uri (git-reference
+                 (url "https://github.com/YingboMa/SafeTestsets.jl")
+                 (commit commit)))
+          (file-name (git-file-name name version))
+          (sha256
+           (base32 "1fb1dfdmiw2ggx60hf70954xlps0r48fcb3k3dvxynlz7ylphp96"))))
+      (build-system julia-build-system)
+      (arguments
+       `(#:julia-package-name "SafeTestsets"))
+      (native-inputs
+       `(("julia-staticarrays" ,julia-staticarrays)))
+      (home-page "https://github.com/YingboMa/SafeTestsets.jl")
+      (synopsis "Julia's testset in a module")
+      (description "This package contains the testset from Julia, packaged into
+a loadable module.")
+      (license license:expat))))
+
 (define-public julia-sortingalgorithms
   (package
     (name "julia-sortingalgorithms")