summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-06-23 17:02:04 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-06-23 17:02:04 +0300
commita2a7cc9bfc4a51a2dde2ea821ed00d88ea5d3976 (patch)
treef1a019f0294f94b40c4bf11729df17c94e15c534
parent92ecee94dd411f9b19f686e7b0fd30c662e94567 (diff)
downloadguix-a2a7cc9bfc4a51a2dde2ea821ed00d88ea5d3976.tar.gz
gnu: lightgbm: Don't use unstable tarball.
* gnu/packages/machine-learning.scm (lightgbm)[source]: Download using
git-fetch.
[arguments]: Adjust custom 'check phase accordingly.
-rw-r--r--gnu/packages/machine-learning.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/machine-learning.scm b/gnu/packages/machine-learning.scm
index cc69aa3ec1..0c02fbcfc7 100644
--- a/gnu/packages/machine-learning.scm
+++ b/gnu/packages/machine-learning.scm
@@ -946,14 +946,14 @@ main intended application of Autograd is gradient-based optimization.")
     (name "lightgbm")
     (version "2.0.12")
     (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://github.com/Microsoft/LightGBM/archive/v"
-                    version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/Microsoft/LightGBM")
+                     (commit (string-append "v" version))))
               (sha256
                (base32
-                "132zf0yk0545mg72hyzxm102g3hpb6ixx9hnf8zd2k55gas6cjj1"))
-              (file-name (string-append name "-" version ".tar.gz"))))
+                "0jlvyn7k81dzrh9ij3zw576wbgiwmmr26rzpdxjn1dbpc3njpvzi"))
+              (file-name (git-file-name name version))))
     (native-inputs
      `(("python-pytest" ,python-pytest)
        ("python-nose" ,python-nose)))
@@ -968,8 +968,8 @@ main intended application of Autograd is gradient-based optimization.")
        #:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda* (#:key outputs #:allow-other-keys)
-             (with-directory-excursion ,(string-append "../LightGBM-" version)
+           (lambda _
+             (with-directory-excursion "../source"
                (invoke "pytest" "tests/c_api_test/test_.py")))))))
     (build-system cmake-build-system)
     (home-page "https://github.com/Microsoft/LightGBM")