summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-01-05 12:35:30 +0100
committerLudovic Courtès <ludo@gnu.org>2016-01-05 13:13:17 +0100
commita2ab82db9ab5d6db86762924d3016aed7c26c315 (patch)
tree4ecacd3bc18bd62055363c43f2d6907d6e8e67c7
parent4f2ca234934983544de73758b6badb61c047f805 (diff)
downloadguix-a2ab82db9ab5d6db86762924d3016aed7c26c315.tar.gz
gnu: python: Honor 'C_INCLUDE_PATH'.
This is a followup to 009b53fd.

* gnu/packages/patches/python-3-search-paths.patch: Check
'C_INCLUDE_PATH' instead of 'CPATH'.
* gnu/packages/patches/python-2.7-search-paths.patch: Likewise.
-rw-r--r--gnu/packages/patches/python-2.7-search-paths.patch6
-rw-r--r--gnu/packages/patches/python-3-search-paths.patch6
2 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/patches/python-2.7-search-paths.patch b/gnu/packages/patches/python-2.7-search-paths.patch
index 6e5339f3a6..ba7235df27 100644
--- a/gnu/packages/patches/python-2.7-search-paths.patch
+++ b/gnu/packages/patches/python-2.7-search-paths.patch
@@ -1,5 +1,5 @@
-Make sure the build system honors CPATH and LIBRARY_PATH when looking for
-headers and libraries.
+Make sure the build system honors C_INCLUDE_PATH and LIBRARY_PATH when
+looking for headers and libraries.
 
 --- Python-2.7.10/setup.py	2015-10-07 18:33:18.125153186 +0200
 +++ Python-2.7.10/setup.py	2015-10-07 18:33:47.497347552 +0200
@@ -9,7 +9,7 @@ headers and libraries.
  
 +        # Always honor these variables.
 +        lib_dirs += os.getenv('LIBRARY_PATH', '').split(os.pathsep)
-+        inc_dirs += os.getenv('CPATH', '').split(os.pathsep)
++        inc_dirs += os.getenv('C_INCLUDE_PATH', '').split(os.pathsep)
 +
          # OSF/1 and Unixware have some stuff in /usr/ccs/lib (like -ldb)
          if host_platform in ['osf1', 'unixware7', 'openunix8']:
diff --git a/gnu/packages/patches/python-3-search-paths.patch b/gnu/packages/patches/python-3-search-paths.patch
index 547feae1b9..7feddb8e30 100644
--- a/gnu/packages/patches/python-3-search-paths.patch
+++ b/gnu/packages/patches/python-3-search-paths.patch
@@ -1,5 +1,5 @@
-Make sure the build system honors CPATH and LIBRARY_PATH when looking for
-headers and libraries.
+Make sure the build system honors C_INCLUDE_PATH and LIBRARY_PATH when
+looking for headers and libraries.
 
 --- setup.py	2015-10-07 23:32:58.891329173 +0200
 +++ setup.py	2015-10-07 23:46:29.653349924 +0200
@@ -13,7 +13,7 @@ headers and libraries.
 -                ]
 -            inc_dirs = self.compiler.include_dirs + ['/usr/include']
 +            lib_dirs = os.getenv('LIBRARY_PATH', '').split(os.pathsep)
-+            inc_dirs = os.getenv('CPATH', '').split(os.pathsep)
++            inc_dirs = os.getenv('C_INCLUDE_PATH', '').split(os.pathsep)
          else:
              lib_dirs = self.compiler.library_dirs[:]
              inc_dirs = self.compiler.include_dirs[:]